APF “Unable to load iptables module” Error

Upon upgrading the Linux Kernel version (usually in CentOS 4.6 - 5) you may get the following error when trying...

Upon upgrading the Linux Kernel version (usually in CentOS 4.6 – 5) you may get the following error when trying to start APF:

Unable to load iptables module (ipt_state), aborting.

To fix this, open /etc/apf/internals/functions.apf and locate the following lines:

ml ipt_state 1
ml ipt_multiport 1

And replace them with:

ml xt_state
ml xt_multiport

Then restart APF.

Leave a reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.